Прошивка для прослушивания интернет радио на роутере. (WifiRadio.SU v114.Full)

Прошивка для прослушивания интернет радио на роутере. (WifiRadio.SU v89.Full)

Прошивка WifiRadio.SU Full с веб интерфейсом, для прослушивания интернет радио на роутерах с прошивкой Openwrt.

*На версиях Openwrt / Lede 17 и выше, возможно не будет работать поддержка формата AAC, либо совсем не работать (в таком случае установите версию Standard).

Возможности:

  1. Поддерживаемые потоки: MP3 (AAC, OGG — опционально при установке mpd-full*)
  2. Индикация проигрываемого трека: есть
  3. Функция Play/Stop: есть
  4. Веб интерфейс: настройки wifi, управление подписками, добавление своих станций, загрузка своих плейлистов, упрощенный пульт управления, управление громкостью, управление переключением станций, управление избранным, управление озвучкой, управление звуковым устройством, обновление прошивки.
  5. Время переключения между станциями: <1 сек.
  6. Поддержка приложения управлением с Android: есть
  7. При нажатии 15 сек. на кнопку WPS создается точка доступа WifiRadio с паролем 12345678, подключившись к ней, можно зайти в веб интерфейс по http://ip адрес/play/, который вы присвоили проводной сети.
История изменений

После обновления прошивки, в веб интерфейсе обязательно нужно обновить страницу клавишами CTRL+F5.

V114.Full (18.04.2020) Важное!

  • Исправлено внезапное воспроизведение при остановленном прослушивании.

V113.Full (14.04.2020) Важное!

  • Критическое исправление.

V112.Full (03.04.2020) Важное!

  • Исправлено произношение погоды и времени по расписанию.

V111.Full (25.03.2020) Важное!

  • Изменение в настройках погоды. Исправлена проблема городов, состоящих из двух слов.

V110.Full (20.03.2020) Важное!

  • Исправлена проблема обновления прошивки и плейлистов при недостатке свободной памяти

V106.Full (29.02.2020) Важное!

  • Исправлена и оптимизирована работа модуля переподключения

V102.Full (19.02.2020)

  • Исправлена ненужная пауза в озвучке, при старте устройства
  • Добавлена возможность произношения приветствия и погоды, через указанные промежутки времени
  • Добавлена функция вкл\выкл уведомления о наличии обновления
  • Добавлена функция вкл\выкл автообновления прошивки

V100.Full (28.01.2020)

  • Исправлены некоторые ошибки

V99.Full (23.12.2019)

  • Исправлены критические ошибки
  • Изменен погодный сервер (openweathermap.org)

V93.Full (01.12.2019)

  • Добавлена возможность добавлять город для погоды вручную.  Для этого просто впишите название города в поле.

V92.Full (22.11.2019)

  • Исправлено произношение погоды.

V91.Full (13.11.2019)

  • Оптимизация размера прошивки.

V89.Full (09.11.2019)

  • Добавлена кнопка Play/Stop в веб интерфейс.
  • Доработано состояние прогресса громкости.

V88.Full (23.10.2019)

  • Оптимизирован модуль инициализации.

V87.Full (22.10.2019)

  • Добавлена возможность листать избранные станции вперед и назад (/www/cgi-bin/wr_nextfav и /www/cgi-bin/wr_prevfav). Функции можно привязать на пульт управления.

V86.Full (09.10.2019) Важное!

  • Важные изменения в работе сервера, на прошивках ранних версий полная работоспособность не гарантируется.

V85.Full (30.09.2019)

  • Добавлена возможность обновления списка профилей с сервера для дистанционного управления с USB устройств (При обновлении, файл конфигурации изменяется!).
  • Добавлен профиль управления переключением станций USB мышью.
  • Исправлена неверная работа кнопки Mute/Unmute на странице виртуального пульта управления.

V84.Full (06.08.2019)

  • Добавлена возможность выбора голоса озвучки (муж/жен).
  • Исправлена проблема с отображением тэгов на некоторых станциях.
  • Обязательно нужно выбрать голос озвучки в веб интерфейсе, и сохранить параметры после прошивки!

V81.Full (12.05.2019)

  • Добавлено оповещение при начале и завершении обновления прошивки.

Порядок установки прошивки на роутер.

Для установки нам понадобится:

  1. роутер прошитый на openwrt с веб интерфейсом LuCI
  2. имеющий usb порт
  3. имеющий ~4 мегабайта свободной flash памяти для установки всех компонентов (можно расширить память при помощи внешней флешки)
  4. также необходим usb звуковой адаптер или usb наушники

Для начала опишу настройку wifi в режиме клиента. После настройки радио будет видеться в Вашей основной сети и иметь доступ к интернет по wifi.

Рекомендуемые настройки сети
Редактируем следующие файлы:

/etc/config/wireless (добавляем в Ваш файл)

config wifi-iface
	option network 'wwan'
	option ssid '*********' #имя Вашей точки доступа WiFi
	option encryption 'psk2' #тип шифрования Вашей точки доступа
	option device 'radio0'
	option mode 'sta'
	option key '********' #пароль Вашей точки доступа

/etc/config/network (полностью заменяем Ваш файл, но параметр option ifname ‘eth0’ меняем на свой)

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option dns '8.8.8.8' 
option ipaddr '192.168.2.1' #ip адрес для Вашего роутера openwrt по кабелю (можно не менять)
option gateway '192.168.1.254' #ip адрес Вашего роутера openwrt в домашней подсети

config interface 'wwan'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1' #ip адрес Вашего роутера или модема с интернетом
option dns '8.8.8.8'
option ipaddr '192.168.1.254' #ip адрес Вашего роутера openwrt в домашней подсети

/etc/config/firewall (полностью заменяем Ваш файл)

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wwan'

config forwarding
	option src 'lan'
	option dest 'wan'

config forwarding
	option src 'wan'
	option dest 'lan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fe80::/10'
	option src_port '547'
	option dest_ip 'fe80::/10'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

После редактирования этих файлов нужно перезагрузить роутер.

Далее устанавливаем саму прошивку.

Автоматический вариант установки через telnet или ssh (putty, xshell):

Если позволяет память, вместо mpd-mini нужно установить mpd-full, тогда появится поддержка AAC потоков. Инструкция по расширению памяти при помощи usb флешки по этой ссылке »

opkg update
opkg install curl mpd-mini mpc kmod-usb-core kmod-usb-audio kmod-sound-core alsa-utils kmod-usb-hid triggerhappy
wget -U "Mozilla/5.0" -O "/tmp/fw.tar.gz" "http://fw.wifiradio.su/download/wifiradio.su_full.tar.gz"
tar -xvzf "/tmp/fw.tar.gz" -C "/"
chmod -R 755 /www/cgi-bin/
chmod -R 755 /etc/wifiradio/
rm -r -f "/tmp/fw.tar.gz"
reboot

После выполнения этих команд роутер перезагрузится и заиграет радио.

Чтобы попасть в web интерфейс с настройками, необходимо в браузере открыть:

http://ip_адрес_роутера/play/

Через web интерфейс можно управлять следующими функциями:

  • Переключать станции
  • Управлять громкостью
  • Управлять избранным (для переключения usb клавиатурой или андроид приложением)
  • Загружать плейлисты
  • Добавлять и удалять станции
  • Управлять подпиской на плейлист
  • Управлять озвучкой станций
  • Настраивать звуковое устройство
  • Настраивать WiFi подключение
  • Обновлять прошивку через OTA

Управление аппаратной кнопкой WPS на роутере: (нажатие 0-1 сек.) следующая станция, (нажатие 2-4 сек.) предыдущая станция, нажатие на кнопку (5-9 сек.) возвращает на первую станцию в списке.

*При использовании usb клавиатуры возможны несовпадения кодов событий, поэтому нужно будет подправить файл example.conf в папке triggerhappy/triggers.d

*Также возможно придется изменить название звукового устройства для управления громкостью. Сделать это можно через веб интерфейс.

Если возникнут вопросы, с радостью отвечу на них.

 

Подписаться
Уведомление о
172 Комментарий
Старые
Новые Популярные
Inline Feedbacks
View all comments
dik_45
dik_45
1 год назад

Скажите пожалуйста как пользоваться пультом ИК, как подключать? что для этого нужно?

dik_45
dik_45
1 год назад

Может вот так сделать, через микрофонный вход https://oldwiki.archive.openwrt.org/doc/howto/lirc-audio_alsa

K0HCТАHTИH KyзьMин
K0HCТАHTИH KyзьMин
1 год назад

Здравствуйте. Очень заинтересовала идея сделать из роутера радио! Экспериментирую на Xiaomi MIR3G. Хочется иногда выключать (пауза или стоп). Когда можно ожидать рабочую версию full под openwrt 18.06…?

K0HCТАHTИH KyзьMин
K0HCТАHTИH KyзьMин
1 год назад

Тогда, может попробовать связаться с разработчиками пакета mpd и рассказать о найденном баге?

K0HCТАHTИH KyзьMин
K0HCТАHTИH KyзьMин
1 год назад

Мне неизвестно в чём выражается и где возникает проблема — только её последствия (не работает).

oka676
oka676
1 год назад

Добрый вечер. Подскажите, как правильно добавлять свою станцию? Нашел адрес потока https://online.krasnoyarskfm.ru/krasnoyarskfm_mp3. В браузере работает, в VLC работает. А при добавлении в web-морду показывает, что играет добавленная станция, а на самом деле играет следующая за ней станция.

oka676
oka676
1 год назад

Спасибо, буду пробовать.

K0HCТАHTИH KyзьMин
K0HCТАHTИH KyзьMин
1 год назад

На TP-LINK MR-3020 V1 c прошивкой LEDE 17.01.6 не работает. Станцию объявляет а не играет.

serj
serj
10 месяцев назад
Ответ для  Админ

скажи пожалуйста, а как поставить пакеты на 15.05 openwrt — они не ставятся. на 18 нет проблем

Александр Гапонов
Александр Гапонов
1 год назад

Здравствуйте. Можно поинтересоваться? После обновления прошивки (WifiRadio.SU v56.Full)
Где должно отображаться определение звукового устройства? У меня ничего не отображается,
как было на v.55 так и на этой, ничего нигде не найду. Использую роутер TL-WR842ND v.1.1
а звуковое устройство USB звуковая карта с проводком, на нем ещё фильтр от помех.
А в общем, всё работает превосходно. Спасибо!

Александр Гапонов
Александр Гапонов
1 год назад

Ранее никогда не находил название устройства, ну если в графе настройки звука, название устройства Speaker. А звук да, регулируется в верху ползунком который от 0 и до 99.

Дмитрий sdd-0
Дмитрий sdd-0
1 год назад

GL-iNet 6416A v1, OpenWrt Chaos Calmer 15.05 r47065 — IP не передается
И если добавлять из базы, озвучки тоже нет.

Дмитрий sdd-0
Дмитрий sdd-0
1 год назад
Ответ для  Админ

После заполнения полей настройки Wifi, все нормально.
Все остальное работает. Спасибо.
А планируется сделать возможность озвучки своих станций?

Дмитрий sdd-0
Дмитрий sdd-0
1 год назад

После последнего обновления, теперь есть все что надо и даже больше.
Огромное спасибо.

Владимир Баринов
Владимир Баринов
1 год назад

Приложение под андроид с какой версией начинает работать?
На 4 андроиде белый экран и всё.

Владимир Баринов
Владимир Баринов
1 год назад
Ответ для  Админ

HTC Desire 200.
4.0.3 андроид. Не работает. Белый экран и тишина.

Владимир Баринов
Владимир Баринов
1 год назад
Ответ для  Админ

С гугл плей уставовил без проблем — совместимо приложение с вашим устройством, пишет. Но не пашет. У вас нет старой версии приложения,в виде apk?

Владимир Баринов
Владимир Баринов
1 год назад

Веб интерфейсом не всегда удобно — приходится комп включать )

Владимир Баринов
Владимир Баринов
1 год назад
Ответ для  Админ

Точно. Спасибо!

Владимир Баринов
Владимир Баринов
1 год назад

юсбишную клаву или мышу можно как нибудь использовать для переключения?

Дмитрий С
Дмитрий С
1 год назад

Подскажите как можно исправить произношение времени.
Сейчас время произноситься на час больше от времени которое установленное на роутере.

Дмитрий С
Дмитрий С
1 год назад
Ответ для  Админ

Часовой пояс установлен правильный. Получается надо изменить часовой пояс, что бы время стало на час меньше от реального.

oka676
oka676
1 год назад

Добрый день. После обновления на 69 full везде вот такая картина: You don’t have permission to access

oka676
oka676
1 год назад

Спасибо, помогло. Обновление было запущено из Android-приложения. Но что-то пошло не так сразу: обычно при начале обновления музыка замолкает, идет обновление прошивки и перезагружается. А в этот раз музыка продолжала играть, потом устройство перегрузилось и больше не заиграло с перечисленными выше симптомами. Подскажите, а голос озвучки менять произвольно нельзя — мужик как-то более четко говорил 😉

oka676
oka676
1 год назад

Подскажите, Android приложение обновляется или нет. Уже давно стоит приложение версии 1, но в Google написано, что версия 1 и обновлено 26 марта 2019. Было бы здорово на сайте выкладывать актуальную APK (не у всех задались отношения с поисковым гигантом)

Владимир Баринов
Владимир Баринов
1 год назад

Очень тихо говорит время погоду и станцию
Потом внезапно Орет

Можно сделать регулировку громкости для системных сообщений и радиостанций
отдельно?

Дмитрий С
Дмитрий С
1 год назад

Добрый день.
После обновления на 79 версию, цикличного озвучивания которое у меня было на 78 версии, нет. Теперь все просто замечательно. Огромное спасибо. Прошивка супер.

Антон Пирогов
Антон Пирогов
1 год назад

Здравствуйте! Сделал все, как в инструкции — нет звука 🙁
Роутер TP-Link 1043 v.1, звуковая Dexp на C-media 108, прошивка OpenWRT 18.06
Подскажите, что еще можно попробовать сделать? Спасибо!

Антон Пирогов
Антон Пирогов
1 год назад
Ответ для  Админ

wifiradio.su_full.tar.gz изменить на wifiradio.su_standart.tar.gz ?

Антон Пирогов
Антон Пирогов
1 год назад
Ответ для  Админ

Спасибо Вам огромное! Все работает! Замечательная прошивка! Еще раз спасибо!

Владимир Баринов
Владимир Баринов
1 год назад

Прикольно, можно свой текст приветствия замутить ))
А возможно загрузку текстового файла приделать, и чтобы читала его?

Аудиокнига получится )

Сергей Простак
Сергей Простак
1 год назад

Как только активирую точку доступа WifiRadio, пропадает соединение с домашним Wifi, а в настройках config wifi-iface автоматом прописываются настройки точки доступа WifiRadio.
Так и должно быть?

Сергей Простак
Сергей Простак
1 год назад

Спасибо Вам большое за программу и за помощь!
Всё отлично работает.

Сергей Белугин
Сергей Белугин
1 год назад

Добрый день!
В последнее время все поля Web-интерфейса WiFi-радио (http://192.168.1.56/play/) содержат «Forbidden. You don’t have permission to access /cgi-bin/wr_liststation on this server.». Соответственно управление радио через Web не работает. Смена браузера ничего не даёт. При этом управление самим маршрутизатором через Web-интерфейс (http://192.168.1.56/cgi-bin/luci и т.д.) работает без проблем.
Что посоветуете?

Сергей Белугин
Сергей Белугин
1 год назад
Ответ для  Админ

Так и сделал, всё заработало, большое спасибо.

Yuri Kazakov
Yuri Kazakov
1 год назад

Все установил. Вопрос в вэб-браузере должен быть звук?? т.к. нет еще usb звуковухи, проверить не могу.

NeLeGal
NeLeGal
1 год назад

вопрос автору. интересует возможность управления балансом или раздельной громкостью по каналам. это возможно на софтовом уровне?
китайская звуковуха на PCM2704
Simple mixer control ‘PCM’,0

Yuri Kazakov
Yuri Kazakov
1 год назад

Спасибо!!! Подключил usb звуковую карту, все работает.
Теперь вопрос как настроить погоду: Москва??

Yuri Kazakov
Yuri Kazakov
1 год назад

ОК, спасибо.
Роутер Asus RT-N16 при нажатии WPS уходит в перезагрузку вместо смены станции. Что нужно поправить, прошивка standart.

Dmitriy Romaschenko
Dmitriy Romaschenko
1 год назад

Доброе время суток всем любителям wi-fi radio от данного автора. Нужна помощь того кто разбирается в openwrt и линуксе. Решил себе в квартире на стадии ремонта вcтроить радио в санузлах. Потолочная акустика. Типа как в магазинах и кафе. Две зоны. Собрал на «коленках» на простом AT90S2313 (attiny2313) устройство. Что делает устройство… следит за двумя ранее установленными выключателями (220V), следит за двумя оптическими датчиками дверей. Управляет основным освещением в двух зонах и активирует программный таймер автоматического отключения освещения (10 и 30 минут). Домочадцы регулярно забывают выключать освещение, надоело… так же управляет светодиодным альтернативным освещением при открывании дверей, так же, со своими… Подробнее »

Dmitriy Romaschenko
Dmitriy Romaschenko
1 год назад
Ответ для  Админ

Спасибо ОГРОМНОЕ, скачал пока архив, вытащил два файла… работает 🙂

Владимир Баринов
Владимир Баринов
1 год назад
Ответ для  Админ

Кстати, отличная мысль — добавить в вебморду управление щедулером по расписанию. В час дня — включить одну станцию, в два часа дня — выключить и другую включить. И регулировка громкости по расписанию неплохо было-бы иметь. В полночь — выключить все на минимум, в 6 утра — включить

NeLeGal
NeLeGal
1 год назад
Ответ для  Админ

Прикрутил себе в вебку редактор уровня приглушения звука для оперативного и облегченного изменения.
дополнения вносились в mute.sh, wr_sound, wr_soundch

Mastit
Mastit
6 месяцев назад
Ответ для  Dmitriy Romaschenko

вижу, что задача решена, но у меня эта задача решалась так — на роутере для радио отдельная вифи сеть, которая включалась/выключалась шедулером по расписанию.

AnderPAN
AnderPAN
11 месяцев назад

Добрый день. Интересует установка версии с поддержкой AAC потоков при установки mpd-full без расширения через USB FLASH, нужно больший объемом флеш памяти, не 64 Мбита, а допустим 128 Мбит хватит ли?!? Или нужно еще и оперативную память увеличивать к примеру 128 Мбайт или более. Какие требование минимальные к памятям у mpd-full. С паяльником дружу, могу для экспериментов помогать…

NeLeGal
NeLeGal
11 месяцев назад
Ответ для  AnderPAN

25Q128 (16mb) вполне достаточно
Свободное место: 57% (7.09 MB)
тут жеж главное не просто спайку (SPI-Flash) заменить, а еще дамп правильно подготовить
лично я увеличивал и оперативную память на некоторых моделях, экспериментировал с увеличением тактовой частоты «камня», скорее любопытства ради…

dik_45
dik_45
8 месяцев назад

Уважаемый админ, хотелось бы увидеть в веб морде кнопку стоп

dmg244 .
dmg244 .
6 месяцев назад

Автор, добавьте в начало плейлистов #EXTM3U. Иначе в сторонних программах для управления mpd названия отображаются в виде vitaminfm, marusya_default и т.п., а не «Витамин FM 90», «Маруся FM».

Павлик Морозов
Павлик Морозов
6 месяцев назад

Админ Приветствую поддержка Flac будет ?

Павлик Морозов
Павлик Морозов
6 месяцев назад
Ответ для  Админ

А воспроизведение через Music Player Daemon можно осуществить он Flac поддерживает вот и ссылку нашел https://openwrt.org/packages/pkgdata/mpd-full

Павлик Морозов
Павлик Морозов
6 месяцев назад
Ответ для  Админ

Все заработало после расширения памяти но очень долго грузит станции минут 10 происходит загрузка

vlad_81
vlad_81
6 месяцев назад

Здравствуйте.
Недавно купил в Алиекспресс:
Роутер:
https://aliexpress.ru/item/32820902708.html?spm=a2g0s.9042311.0.0.32b433edl7WZu6
USB Звуковую карту:
https://aliexpress.ru/item/4000004784921.html?spm=a2g0s.9042311.0.0.35fb33edPVomPQ
USB HUB:
https://aliexpress.ru/item/33030134506.html?spm=a2g0s.9042311.0.0.32b433edl7WZu6
Пульт управления с USB приемником:
https://aliexpress.ru/item/4000054048925.html?spm=a2g0s.9042311.0.0.13d333edSyh3RO
Все прошил по инструкции: «Прошивка для прослушивания интернет радио на роутере. (WifiRadio.SU v99.Full)». В командах загрузки прошивки устанавливал mpd-full. После прошивки вхожу в web интерфейс нормально, но совсем нет звука и нет никакой реакции на пульт управления.Пробовал напрямую подключать к роутеру USB мышь (2,4G Wireless Optical Mouse), тоже никакой реакции.Подскажите пожалуйста в чем может быть причина отсутствия звука и возможности управления?

Mastit
Mastit
6 месяцев назад
Ответ для  vlad_81

у меня такая звуковушка увиделась роутером только после установки пакета kmod-usb-ohci
возможно ещё kmod-usb-uhci и kmod-usb2 понадобятся…

Сергей Казанков
Сергей Казанков
6 месяцев назад
Ответ для  Mastit

У товарища прошивка неизвестного происхождения, там похоже много чего не хватает… и «такая» звуковушка, известна например мне, как минимум в двух вариантах начинки.
Однако подтверждаю, в моей openwrt установлены пакеты kmod-usb-ohci и kmod-usb2 — и такая звуковушка работает.

Mastit
Mastit
6 месяцев назад

я так понимаю «поддержки звука» в «базе» openwrt нет совсем (я когда в заводские роутер сбрасываю там ни одного нужного пакета нет по звуку), поэтому происхождение прошивки имхо не при делах.

И тогда вдогонку к автору проекта предложение — добавить эти (kmod-usb-ohci kmod-usb-uhci и kmod-usb2) в инструкцию по настройке радиороутера.

Сергей Казанков
Сергей Казанков
6 месяцев назад
Ответ для  Mastit

Происхождение прошивки ещё как «при делах». У меня openwrt 18.06 из снапшота с сайта openwrt.org — всё там есть.

Mastit
Mastit
6 месяцев назад
Ответ для  Mastit

так это не «происхождение», а «сборка», как справедливо заметили выше — у меня 15.05.1 — уже и не помню точно как/чего (радио пилил года полтора назад) но выбирал сборку полегче (из вполне официальных источников), чтоб в хиленький дир320в2 влезло — соответственно и набор пакетов там «базовый».

vlad_81
vlad_81
6 месяцев назад

Когда вхожу в web интерфейс роутера слева название «NETGEAR genie», а внизу экрана надпись: Powered by LuCi Master (git-19.121.62139-9ec402e / OpenWrt R9.5.1 By Lean / TracMouse (Theme). По этой надписи можно определить версию?Если не подходит укажите пожалуйста ссылку на новую, в которой все будет работать нормально.
Пробовал подключать звуковуху напрямую к USB роутера — результата нет никакого.Как можно проверить, что определяется звуковушка?
Насчет ошибок при установке пакетов ничего пока сказать не могу, ставил через PUTTY в режиме SSH.Ошибки можно найти если внимательно посмотреть в тексте который появляется во время установки пакетов в окне терминала?Я правильно понимаю?

vlad_81
vlad_81
6 месяцев назад

Установил приложение на планшет, при открытии появляется окно предупреждения: Bad argument to ThumbPosition. The operation ThumbPosition cannot accept the argument:,[«»]. И внизу надпись End Application. Если нажимаю вне окна предупреждения — оно исчезает и когда пробую менять станции на планшете потом обновляю на компьютере в web интерфейсе — переключение происходит (управление с планшета работает).Что посоветуете сделать?

vlad_81
vlad_81
6 месяцев назад

При клике мышкой на иконке открывается новая страница (по ссылке: http://192.168.1.254/cgi-bin/wr_soundview ) — но она пустая, а в поле Название устройства — слово Speaker.
У меня такой вот китайский роутер с такой вот непонятной OpenWrt прошивкой. Подскажите пожалуйста, существет ли какой-либо способ узнать версию установленной OpenWRT прошивки из командной строки в терминале?
Вот по этой сыслке: http://www.minihere.com/youku-yk-l1-openwrt-and-ddwrt-firmware-download.html внизу есть ссылка на скачивание прошивки: OPENWRT Firmware 15.05.01 (LAN 1 port is WAN Port): http://www.mediafire.com/file/me946dho7obbzhv/openwrt-15.05.1-ramips-mt7620-Lenovo-y1-squashfs-sysupgrade.bin/file — ее можно скачивать и установить, или лучше скачать на странице проекта OpenWRT для моего роутера YK-L1: https://openwrt.org/toh/hwdata/youku/youku_yk1 есть прошивка: http://downloads.openwrt.org/releases/18.06.5/targets/ramips/mt7620/openwrt-18.06.5-ramips-mt7620-youku-yk1-squashfs-sysupgrade.bin — ее можно устанавливать?

Сергей Казанков
Сергей Казанков
6 месяцев назад
Ответ для  vlad_81

понакупают всякого хлама недокументированного….
https://4pda.ru/forum/index.php?showtopic=890458

Владимир Баринов
Владимир Баринов
6 месяцев назад

Для Synology — бы такую прогу….

Сергей Казанков
Сергей Казанков
6 месяцев назад

А оно там надо?
Подходящий (вот прям подходящий — имеющий под себя openwrt 15-й версии, и правильный объём флэш и озу) микро роутер, стоит на али чуть более 1000 рублей (на каком-нибудь авито можно и дешевле найти) — купите, прошейте, установите, да пользуйтесь)
Это если роутер, а так я вам с ходу ещё могу назвать несколько реализаций интернет-радио, на автономных от пк устройствах.
https://aliexpress.ru/item/32273181856.html?spm=a2g0s.8937460.0.0.10622e0eAWlySt

Владимир Баринов
Владимир Баринов
6 месяцев назад

У меня Nexx 3020. Не всегда включать удобно. А Синология крутится круглосуточно

Сергей Казанков
Сергей Казанков
6 месяцев назад

Так, постойте… ведь есть же https://www.synology.com/ru-ru/dsm/packages/SqueezeCenter
У вас же там х86 и линукс какой то свой, да? Не знаю как там с поддержкой usb аудио, а на arm вполне можно установить LMS и настроить играть «на себя» — http://ixbt.photo/?id=album:65286
я правда использую встроенный в процессор аудиокодек.

Владимир Баринов
Владимир Баринов
5 месяцев назад

Не то это

Mastit
Mastit
6 месяцев назад

так пусть и Nexx крутится круглосуточно — делов-то)))

Владимир Баринов
Владимир Баринов
5 месяцев назад
Ответ для  Mastit

Блин. Тоже вариант

Сергей Казанков
Сергей Казанков
5 месяцев назад

Почему «не то это»? Вы пробовали и у вас не получилось?
Я же не от балды написал — по второй ссылке в сообщении, один из моих интернет-приёмников. Вполне рабочий и удобный вариант, играет вообще любые потоки что есть в сети (ну и локально разумеется).

Сергей Казанков
Сергей Казанков
5 месяцев назад

А я всё таки купил себе ещё и такой… Идеальный роутер для этого проекта, берите пока продаётся. Накатил openwrt 15.05.1 из архива openwrt.org, подправил пути к репозиторию, поставил mpd-full (играет, соответственно, всё популярное — mp3/aac/ogg), радоваюсь. Пойдёт на замену моему TL MR-3020 v3 (и для него работа найдётся). Это уже четвёртый микророутер в моём пользовании)

Сергей Белугин
Сергей Белугин
6 месяцев назад

Добрый день! Можно ли и как через данное WifiRadio вывести звук с компа (н-р, с YouTube), который находится в одной сети с WifiRadio?

Mastit
Mastit
6 месяцев назад
Ответ для  Сергей Белугин
Сергей Казанков
Сергей Казанков
6 месяцев назад
Ответ для  Сергей Белугин
dik_45
dik_45
5 месяцев назад

Интересно было бы увидеть в данном проекте управление выбором станции через энкодор.

dik_45
dik_45
5 месяцев назад
dik_45
dik_45
5 месяцев назад

Хочется экран Олед и инкодер, тогда вообще цены не было

Сергей Казанков
Сергей Казанков
5 месяцев назад
Ответ для  dik_45

Причём, без экрана со списком доступных станций, смысл от энкодера исчезающе мал. Да и вообще любых физических кнопок для выбора станций, когда станций в листе больше трёх. Но кнопки хоть почётче под пальцами, чем модная крутилка. Моё мнение (один чел с ардуино.ру хорошо сформулировал, жаль ссылку не найти), не навязываю)

Сергей Казанков
Сергей Казанков
5 месяцев назад
Ответ для  dik_45

А в качестве регулятора громкости, как по ссылке вашей — вообще смысла нет) После усб звуковухи, всё равно активная аккустика — любой переменный резистор справится. Если после наушники — берем звуковуху с регулировкой громкости)

andrey68rus .
andrey68rus .
5 месяцев назад

Ув. Автор, а у проекта имеется git?

andrey68rus .
andrey68rus .
5 месяцев назад
Ответ для  andrey68rus .

А то было бы очень замечательно наблюдать за историей изменений, и пушить реквесты.

andrey68rus .
andrey68rus .
5 месяцев назад
Ответ для  Админ

Очень жаль ( Адаптирую Вашу прошивку для Xiaomi Mi Speaker. По ходу ряд исправлений внес. )
Bugreport: В приложении ошибка Bad arguments ThumbPosition cannot accept the arguments: , [«»].
Можете оставить свой телеграмм или мне написать @andr68rus ?

Сергей Ганжуро
Сергей Ганжуро
4 месяцев назад

Здравствуйте хочу установить какой роутер в машину посоветуйте что поставить на ваш взляд. Интернет в авто достойный. Если возможно сделать заказ на такое оборудование напишите ваше предложение. моя почта sergey113135@ya.ru

Андрей Разживин
Андрей Разживин
3 месяцев назад

Спасибо большое, система огонь) Полностью проверю, как работает, чуть позже — когда usb-аудио-свисток из Китая придет, но уверен, что все будет классно. А так внешне все работает — поток бежит, вебка работает, приложение работает. Но есть пара вопросов: 1. Где можно изменить параметр автостарта проигрывания радио после перезагрузки? 2. Можно ли в приложении/вебке отображать, проигрывается сейчас музыка или нет? Т.е. стандартную схему — когда играет, значок стоп, когда нет — значок плей? А то сейчас, без подключенных колонок приходится отслеживать только по увеличению трафика) Ага, с отображением кажется нашел — там не прописывается адрес станции во время остановки. Но вопрос… Подробнее »

Андрей Разживин
Андрей Разживин
3 месяцев назад
Ответ для  Админ

Спасибо. Т.е. изменить параметр автопроигрывания нельзя, я правильно понял?

Андрей Разживин
Андрей Разживин
3 месяцев назад
Ответ для  Админ

В /etc/config лежат два файла — wifiradio и system, но там не нашел нужной строки. В wifiradio появляется строка «option playpause ‘stop'», но только во время проигрывания. Не там копаю, видимо.

Андрей Разживин
Андрей Разживин
3 месяцев назад
Ответ для  Админ

Ага, и нем, как я понимаю, нужно написать mpc stop.

Андрей Разживин
Андрей Разживин
3 месяцев назад
Ответ для  Админ

Спасибо)

Михаил Холод
Михаил Холод
3 месяцев назад

Здравствуйте, запарился я с mr3020, mtd-full так и не смог поставить, пробовал разные spi и на 8 и на 16мб. В итоге нашел в закромах asus rt-n14u. На него всё встало без проблем и памяти еще осталось 7мб. Пишите если нужна инфа, модель можно добавить в шапку, для того чтобы желающие повторить проект знали какой роутер можно использовать, так как я сам долго искал подходящий.